Delayed SIM Operations for G1 (89445*) profiles

Incident Report for Hologram

Resolved

The backlog has been cleared.
Posted Dec 27, 2025 - 02:08 UTC

Investigating

There is a currently a backlog delaying SIM operations on G1 profiles (ICCID prefix 8944*). Backlog is processing and some customers may experience delays. Cellular network and other API services are unaffected.
Posted Dec 26, 2025 - 19:49 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).