Data Usage Reporting Delay

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted May 09, 2025 - 12:03 UTC

Monitoring

We recently identified a delay in the processing of device usage and session data. This has been resolved, and the system is now recovering.

Some customers may notice missing or delayed usage data in the Dashboard and API. This data is not lost — it will begin appearing gradually as the backlog is cleared. We expect full recovery over the next several hours.

There is no impact to device connectivity.
Posted May 08, 2025 - 22:59 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).