Delayed SIM Operations on Global-1 SIMs

Incident Report for Hologram

Resolved

The backlog has been cleared.
Posted Feb 21, 2026 - 01:13 UTC

Investigating

There is a currently a backlog delaying SIM operations on some of the Global-1 profiles. Backlog is processing and some customers may experience delays.

Cellular network and other API services are unaffected.
Posted Feb 20, 2026 - 22:17 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).