We are continuing to investigate this issue and there is no new information at this time. We will provide the next update when new information is available.
Posted Aug 27, 2026 - 03:26 UTC
Investigating
We are investigating reports of degraded data performance affecting devices in the United States (AT&T, T-Mobile, and Verizon) on our Global-3 (G3) profile SIMs (ICCID prefix 894642*).
Affected devices are attaching normally and maintaining data sessions, but transfers involving larger payloads are seeing significantly reduced throughput and elevated failure rates. Sessions passing small amounts of data appear to be unaffected.
We have engaged our network partners and dedicated engineers are actively investigating. Devices outside the United States are not currently believed to be impacted.
The next update will be provided within 60 minutes, or sooner if we have new information.
Posted Aug 27, 2026 - 02:27 UTC
This incident affects: Cellular Networking (Global Cellular Data Network).