Delayed SIM Operations

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 16:06 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 29, 2025 - 03:35 UTC

Monitoring

There is a currently a backlog of operations delaying SIM operations on G2 carriers 8944*. Backlog is processing and some customers may experience delays. Cellular network and other API services are unaffected.
Posted Aug 29, 2025 - 03:35 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).