Delayed SIM Operations
Incident Report for Hologram
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 15:33 UTC
Investigating
There is a currently a backlog of operations delaying SIM operations on some carriers (activations, suspensions, data usage reports, etc). Backlog is processing and some customers may experience delays. Cellular network and other API services are unaffected.
Posted Jan 30, 2024 - 21:17 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).