Delayed SIM Operations for Global-1 (prefix 89445*) and USA2 (prefix 89148*)

Incident Report for Hologram

Resolved

This backlog has been cleared.
Posted Mar 04, 2025 - 14:12 UTC

Investigating

There is a currently a backlog of operations delaying SIM operations on our Global-1 and USA2 carrier. Backlog is processing and some customers may experience delays with some SIM operations. Cellular network and other API services are unaffected.
Posted Mar 03, 2025 - 21:27 UTC
This incident affected: Cellular Networking (SMS over cellular - Device Terminated) and SIM Management (SIM Card Administrative Operations).