Partial Global-2 Outage affecting SIMs with prefix 8935*

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 00:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We are seeing traffic starting to return to normal levels.
Posted Mar 20, 2026 - 22:54 UTC

Investigating

One of our upstream network partners is experiencing an outage affecting new registrations on their 2G, 3G, and 4G/LTE networks. We have notified the partner and are working with them to resolve this issue. This outage only affects SIM cards with the ICCID prefix 8935*.
Posted Mar 20, 2026 - 19:57 UTC
This incident affected: Cellular Networking (Global Cellular Data Network, SMS over cellular - Device Terminated, SMS over cellular - Device Originated).