Backlog of usage reporting on Global-1 (ICCID prefix 89445*) profiles

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 14:03 UTC

Update

There is a fix in place. Engineering team is continuing to monitor.
Posted Mar 18, 2026 - 18:31 UTC

Monitoring

We are experiencing a backlog of incoming usage messages from our upstream provider on Global-1 profiles. Usage reporting in the Dashboard and API is currently delayed while the backlog is being processed. Usage reporting is not affected on any other profiles.

Connectivity is not affected on any profiles.
Posted Mar 18, 2026 - 12:02 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).