Billing Issue: Duplicate SIM Charges on Renewal

Incident Report for Hologram

Resolved

The issue where some SIMs are being charged their monthly recurring cost (MRC) multiple times during their billing cycle renewal has been resolved.

We will apply necessary billing corrections to impacted accounts.
Posted May 12, 2025 - 21:29 UTC

Update

We’ve deployed a fix for the issue that was causing some SIMs to be charged multiple times during their monthly renewal. Affected services have caught up and are now operating normally, including data usage reporting and billing cycle processing.
Posted May 10, 2025 - 02:23 UTC

Monitoring

We’ve deployed a fix for the issue that was causing some SIMs to be charged multiple times during their monthly renewal. Affected services have caught up and are now operating normally, including data usage reporting and billing cycle processing.

As a precaution, we are temporarily continuing to not suspend SIMs or organizations with negative balances on prepaid accounts, while we finish applying billing corrections.
Posted May 09, 2025 - 19:09 UTC

Identified

We’ve identified the root cause of the issue that was causing some SIMs to be charged their monthly renewals multiple times.

We are currently publishing a fix for this error. Until the update is deployed, SIMs will not pause when reaching their data limit, and customers on prepaid plans will not have their balance auto-refilled.

Additionally, data usage reporting via our API will be delayed by several hours.

We are actively working to restore the underlying services and will be applying necessary billing corrections to impacted accounts once the issue is resolved.
Posted May 09, 2025 - 18:08 UTC

Investigating

We’ve identified an issue where some SIMs are being charged their monthly recurring cost (MRC) multiple times during their billing cycle renewal. Our team is actively investigating the root cause and working to implement a fix.

Once the issue has been resolved, we will apply any necessary billing corrections to impacted accounts.

If you have any questions please reach out to support@hologram.io.

Thank you for your patience and understanding.
Posted May 09, 2025 - 15:01 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).