Delayed SIM Operations and Connectivity on G3 profiles (ICCID prefix 89464*)

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 02:12 UTC

Identified

There is a backlog of SIM operations which is delaying activations, and as a result connectivity is affected for those specific SIMs. We are actively working on restoring service and will provide updates accordingly.
Posted Apr 21, 2025 - 18:45 UTC
This incident affected: Cellular Networking (Global Cellular Data Network) and SIM Management (SIM Card Administrative Operations).