Delayed bulk SIM Operations

Incident Report for Hologram

Resolved

The backlog has cleared.
Posted Jan 10, 2026 - 03:14 UTC

Monitoring

There is a currently a backlog delaying SIM operations submitted in bulk. We are currently monitoring the backlog which is processing, but some customers may experience delays when submitting bulk operations.

Cellular network and other API services are unaffected.
Posted Jan 09, 2026 - 17:19 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).