Cellular connectivity interruption on some SIM cards
Incident Report for Hologram
Postmortem

On March 14th, Hologram experienced degraded service, eventually resulting in a loss of connectivity, with one of our connectivity partners. This incident impacted some customers who use SIMs/profiles with ICCIDs beginning with the 8944* prefix. During the incident, devices using these SIMs/profiles experienced a cellular data outage and degraded cellular data connectivity.

Incident Summary and Impact

On March 14th around 23:00 UTC, one of our connectivity partners encountered degraded signalling service via one of their upstream interconnect providers. This degraded signalling eventually resulted in a disruption of all signalling via that interconnect provider.

The loss of control plane signalling traffic resulted in the inability for affected devices to attach to towers, establish new data connections, and maintain existing data connections. The resulting degraded service and outage affected all SIMs/profiles with ICCIDs beginning with the 8944* prefix that attempted connections during the incident. Customers using other profiles were unaffected.

The upstream interconnect provider restored signalling services by 02:50 UTC on March 15th, at which time affected devices began reconnecting. Hologram monitored progress until all devices were restored.

Root Cause and Technical Description

Root cause analysis is underway, and the interconnect provider and our connectivity partner are working to reproduce the issue in a sandboxed environment. This work is to confirm root cause and determine why performance degradation occurred and did not remain more isolated.

Timeline

Root cause analysis is ongoing and we will post an update in the coming weeks including the timeline of events.

Remediation and Next Steps

This incident had a widespread impact, and we take reliability very seriously. While Hologram and its partners implement systems and safeguards to maximize reliability, and we observed an improved recovery during this incident due to prior implemented changes, we will identify any additional areas of improvement and work to uncover any other containment gaps to prevent a recurrence of this type of root cause.

Root cause analysis is ongoing and we will post an update in the coming weeks as to our findings and our next steps for improved containment and prevention based upon what is learned from this incident.

Conclusion

Our aim at Hologram is to provide the most reliable cellular connectivity product available, and we clearly fell short of our customer expectations with this incident. Although the root cause was with an upstream partner, we are ultimately accountable and are deeply sorry for the disruption to our customers who were unable to use cellular data on this profile as expected due to the outage.

Posted Apr 01, 2024 - 19:30 UTC

Resolved
We've been monitoring the fix from our upstream providers and we can confirm the issue has been resolved. We will provide more information as we receive it and review the root cause analysis.
Posted Mar 15, 2024 - 15:30 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 15, 2024 - 15:29 UTC
Monitoring
Our upstream provider has reported the issue is fixed and we are now monitoring to ensure that connectivity has been completely restored.
Posted Mar 15, 2024 - 05:27 UTC
Investigating
We are seeing an issue preventing some SIM cards with the 89445* prefix from being able to attach to the network and pass data.. We have escalated this to upstream carrier partners and they are actively investigating.
Posted Mar 15, 2024 - 01:08 UTC
This incident affected: Cellular Networking (Global Cellular Data Network).