Partial Global-2 (8935*) outage

Incident Report for Hologram

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 16:28 UTC

Investigating

One of our upstream network partners is experiencing an outage affecting new registrations on their 2G, 3G, and 4G/LTE networks. We have notified the partner and are working with them to resolve this issue. This outage only affects SIM cards with the ICCID prefix 8935*.
Posted Feb 12, 2026 - 14:30 UTC
This incident affects: Cellular Networking (Global Cellular Data Network).