Connectivity issues on Global-3 (G3) profiles (ICCID prefix 894642*)

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 07:03 UTC

Monitoring

Our metrics show traffic is returning to normal levels and we'll continue monitoring and update accordingly.
Posted Mar 12, 2026 - 04:31 UTC

Investigating

We are currently investigating a reported issue on our Global-3 (G3) profiles (ICCID prefix 894642*). We are seeing devices having trouble establishing and maintaining sessions on 4G/LTE. We are actively working with our upstream partners on a resolution and we'll provide updates as more information becomes available.
Posted Mar 12, 2026 - 03:43 UTC
This incident affected: Cellular Networking (Global Cellular Data Network, SMS over cellular - Device Terminated, SMS over cellular - Device Originated).