Delayed SIM Operations

Incident Report for Hologram

Resolved

Backlog has been cleared and SIM operations are back to normal.
Posted Feb 15, 2025 - 00:56 UTC

Identified

We are currently experiencing delays in SIM-related operations due to an increased backlog. This may impact the following services:
• SIM activations
• State changes (e.g., suspensions, reactivations)
• Plan changes

Our team is actively working to process the backlog and restore normal operation times as soon as possible. We apologize for any inconvenience and appreciate your patience.

For urgent requests or further assistance, please reach out to our support team.
Posted Feb 14, 2025 - 21:40 UTC
This incident affected: SIM Management (SIM Card Administrative Operations, Hyper SIM EUICC Operations).