G2 (89357*) Issue with CAT-M Connectivity on Verizon (US)

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 15:44 UTC

Investigating

We have identified abnormal behavior on G2 (89357*) sims roaming on the Verizon CAT-M network.

To ensure network stability and uninterrupted connectivity, access to the Verizon CAT-M network has been temporarily disabled for G2 SIMs only.

We are actively working with our upstream connectivity partners to investigate and restore normal service.
Posted Nov 03, 2025 - 14:50 UTC
This incident affected: Cellular Networking (Global Cellular Data Network).