Connectivity issues on G3 SIMs/profiles

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 15:44 UTC

Monitoring

We’ve increased capacity on our PGW (Packet Gateway) network nodes and are already seeing significant improvement in performance. Our team is actively monitoring to ensure stability and will provide further updates as needed.
Posted Apr 18, 2025 - 13:26 UTC

Investigating

We are currently investigating a reported issue on our G3 SIMs/profiles (ICCID prefix 89464*). We are seeing high percentages of packet loss with both existing and new data sessions.

We are actively working with our upstream partners on a resolution. We will provide updates as more information becomes available.
Posted Apr 18, 2025 - 02:46 UTC
This incident affected: Cellular Networking (Global Cellular Data Network).