Delayed Usage Reports in Dashboard

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 19:57 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 31, 2026 - 17:52 UTC

Monitoring

There is an ongoing analytics platform outage that is impacting our reporting. We expect recovery within 1hr.
Posted Aug 31, 2026 - 17:50 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).