Delayed SIM Operations
Incident Report for Hologram
Resolved
This incident has been resolved.
Posted Jan 20, 2024 - 00:57 UTC
Identified
We've identified a backlog on our SIM operations.

Activations, state changes and plan changes might be delayed while the system processes the backlog.
Posted Jan 19, 2024 - 22:32 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).