Delayed SIM operations on Global-1 profiles (ICCID prefix 89445)

Incident Report for Hologram

Resolved

We are caught up on all delayed operations.
Posted May 19, 2026 - 14:26 UTC

Investigating

We are experiencing a delay on SIM card administrative operations (activations, plan changes, state changes) on our Global-1 profiles. Operations done through the Dashboard and API are impacted.

Connectivity remains unaffected. All other profiles remain unaffected.
Posted May 18, 2026 - 21:13 UTC
This incident affected: SIM Management (Device Dashboard, REST API, SIM Card Administrative Operations).