Connectivity issues on USA-2/Verizon profiles (ICCID prefix 89148*)

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 05:01 UTC

Update

Our metrics show that sessions and data transfer have stabilized to pre-incident levels.

We are continuing to monitor for the time being for any further issues and will provide updates as needed.
Posted Feb 25, 2026 - 03:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 14:34 UTC

Investigating

We are currently investigating a reported issue on our USA-2/Verizon profiles (ICCID prefix 89148*). We are seeing devices having trouble establishing and maintaining sessions on 4G/LTE. We are actively working with our upstream partners on a resolution and we'll provide updates as more information becomes available.
Posted Feb 24, 2026 - 04:13 UTC
This incident affected: Cellular Networking (Global Cellular Data Network, SMS over cellular - Device Terminated, SMS over cellular - Device Originated).