Payments Processing Degraded Service
Incident Report for Hologram
Resolved
This incident has been resolved and payments processing restored to standard service level
Posted Jun 18, 2020 - 21:01 UTC
Identified
Our payments processing provider has identified degraded service that may affect users ability to process payments. We will monitor the situation as it recovers. Hologram API, Dashboard, and cellular network connectivity unaffected.
Posted Jun 18, 2020 - 20:53 UTC
This incident affected: Main Website and Store.