Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 08:59 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Mar 15, 2026 - 08:58 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 07:57 UTC
Scheduled
We are currently investigating an issue causing delays in our data available to the dashboard. Usage and billing summaries may be delayed more than usual. Normal sim operations are unaffected, and sim details will still update normally during this period.
Our team is actively working to identify the root cause and will provide updates as soon as we have more information.
Thank you for your patience.
Posted Mar 15, 2026 - 07:56 UTC
This scheduled maintenance affected: SIM Management (Data Usage Reporting and Billing).