Delayed Sim Operations on sims prefix 89357*
Incident Report for Hologram
Resolved
The issue was promptly resolved, SIM operations should be back to normal.
Posted May 31, 2023 - 17:13 UTC
Investigating
We're investigating an incident involving sim operations (Activations, state changes, plan changes, etc) for SIMs using our ICCID prefix 89357*
Posted May 31, 2023 - 16:46 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).