Delayed reporting on US2 profiles (ICCID prefix 89148)

Incident Report for Hologram

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 27, 2026 - 21:37 UTC

Investigating

Verizon is currently experiencing an issue where data usage/reporting is delayed on US2 profiles (Verizon-native). We are working with Verizon's team to get this resolved and the usage backfilled. We will provide updates as soon as we have further information.

Reporting on all other profiles remains unaffected. Connectivity remains unaffected on all profiles.
Posted Apr 27, 2026 - 21:11 UTC
This incident affects: SIM Management (Data Usage Reporting and Billing).