Delayed SIM State Changes on Global-1 Profiles (ICCID prefix 894450)

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 16:23 UTC

Investigating

We are currently experiencing a backlog causing delays in SIM state changes for Global-1 profiles. Customers may experience longer than expected processing times when activating, deactivating, or pausing SIMs. We are unable to provide an estimated resolution time at this point, but we are actively working to clear the backlog.

Cellular network connectivity and other API services are unaffected.
Posted Jun 02, 2026 - 21:23 UTC
This incident affected: SIM Management (SIM Card Administrative Operations).