Delay in data usage reporting

Incident Report for Hologram

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 03:59 UTC

Identified

Parts of Dashboard's usage reporting are experiencing delays and have not been updated since approximately 22:00 UTC on 6/18. The following reports are affected:

1. All reports in the Usage tab
2. the "Data usage" tab of the SIM Details page

We have identified the root cause and are working with one of our data warehousing vendors to resolve the issue.

Connectivity and billing are not affected.
Posted Jun 19, 2025 - 01:37 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).