Delayed Billing and Usage Reporting
Incident Report for Hologram
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 14:56 UTC
Investigating
We are investigating delays in data usage reporting, data limits, and billing operations. Network connectivity and other services are unaffected by this issue.
Posted Jul 28, 2022 - 22:00 UTC
This incident affected: SIM Management (Data Usage Reporting and Billing).