Delayed SIM Operations
Incident Report for Hologram
Resolved
SIM operations restored to normal service levels. Previously held SIM operations may experience slight delay as orders catch up. Please reach out to support@hologram.io if you experience any further issues
Posted Jan 09, 2018 - 20:52 UTC
Investigating
An issue has been identified delaying SIM operations including activations, plan changing, pause/resume. Cellular network and data engine services are unaffected.
Posted Jan 09, 2018 - 20:45 UTC